Ogni volta che la Mozilla Foundation rilascia una nuova versione del suo browser, c’è una domanda che si ripete sistematicamente: “Funzioneranno le mie estensioni con questa nuova release?” E’ lecito chiederselo, in quanto molti autori di estensioni, non permettono l’installazione del proprio software su versioni nuove del browser. Questo fa si che, quando si aggiorna, FireFox lamenti il fatto di non poter utilizzare una particolare estensione in quanto “non compatibile”. Ecco quindi come forzare un’installazione:

COME FORZARE L’INSTALLAZIONE DELLE ESTENSIONI NON COMPATIBILI IN FIREFOX 4.0 BETA

1. Errore incompatibilità
1. Installando un’estensione non progettata per la nuova versione di Firefox ecco il messaggio di errore che si presenta.
2. Modifiche sotto il cofano 3. La stringa giusta
2. Uno dei “luoghi” prediletti dai “Firefox hacker” è la pagina about:config da cui è possibile modificare moltissime opzioni del browser open source della Mozilla Foundation. Tuttavia è molto facile farsi intimorire dall’estetica spartana della pagina e dall’infinità di impostazioni presentate. Per accedere a questa pagina digitiamo about:config nella barra degli indirizzi digitiamo Invio e clicchiamo sul pulsante Farò attenzione, lo prometto. Clicchiamo col tasto destro in un punto qualsiasi e scegliamo New/Boolean.

3. Nella finestra pop-up digitiamo uno dei valori sotto indicati, a seconda della versione in uso:

  • 4.0 Beta: extensions.checkCompatibility.4.0b
  • 4.0 Release: extensions.checkCompatibility.4.0
4. Inseriamo il valore 5. Installazione senza intoppi
4. Quindi impostare il valore su false.

5. A questo punto l’installazione avverrà con successo.

MAGGIORI INFORMAZIONI
SOURCE DOWNLOAD FIREFOX BETA 4.0

Leggi anche: